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Moglue‟s desktop builder allows publishers, amateur authors and artists a way to quickly and  

easily create interactive ebooks and release them as apps. No programming required. 

 

Moglue‟s application is the first of its kind, utilizing a non-technical, friendly user-interface.  It will  

be fully supported across Mac (10.6 or later) and Windows (XP or later), with plans for Linux 

support as well. The content is made once, and can be published to both Android and iOS devices.  

 

 

What is an interactive ebook? 

 

 

 

 

 

 

 

 

 

 

 

Telling stories is both universal and eternal; the only change has been the way in which they are  

told. Books have traditionally told stories through text and pictures, and until recently these  

communications have been mostly one-way. Smart touchscreen devices are changing this: stories  

are things we can touch, tilt, listen to and tweet. We intend to build an open community where  

any creative, imaginative person will be able to use our platform to create and share deep,  

interactive stories. 

 

1. Moglue Builder  /  1-1) About Moglue‟s Builder 

1-1) About Moglue’s Builder 
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„Café Lunner‟  Copyright ⓒ 2011 Moglue 

◀ Back to Contents 



1-2) Downloading & Running the Builder 
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Downloading 

 

To create interactive e-books, you will need to download the Moglue builder desktop application. 

Go to www.moglue.com/platform, and select the appropriate version for your operating system. 

 

 

 

 

 

 

 

 

 

 

 

You can also do a live preview of your interactive ebook on any iOS or Android device. Download 

our “Moglue Books” app, which includes a viewer component that allows you to preview your 

books. Go to www.moglue.com/storeapps/ and select the appropriate app for your mobile  

device. 

 

 

 

 

 

 

 

 

 

 

 

· Apple App Store: http://itunes.apple.com/hk/app/mogluebooks/id443199934?mt=8/ 

· Android Market: (coming soon) 

1. Moglue Builder / 1-2) Downloading & Running the Builder 

◀ Back to Contents 

http://www.moglue.com/platform
http://www.moglue.com/storeapps/
http://itunes.apple.com/hk/app/mogluebooks/id443199934?mt=8/
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Running the Builder 

 

Click the Moglue icon to run the builder; Follow the steps to install the Moglue builder. 

Large size Icon Medium, Small size Icon 

Splash Screen 

1. Moglue Builder / 1-2) Downloading & Running the Builder 

After installation, run the builder. You will see a brief splash screen, after which the workspace 

should appear. You are now ready to make your own interactive ebook! 

◀ Back to Contents 



2-1) Panels 
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❶ Top Menu 

Save, load, preview, show/hide panels; standard fare. 

❷ Toolbar 

Shortcuts for main builder functions. 

❸ Image Library 

Imported images and artwork appear here. We support JPEG, GIF, TIF and PNG files. 

❹ Action Library 

There are two types of effects: actions and sounds. Actions from our pre-made Action Library can be assigned 

to images, and multiple actions can be assigned to a single image. Sounds are also assignable to images. You 

can import your own sounds using either the Top Menu or the „Import‟ icon located in the Toolbar. We 

support MP3, M4A, MP4 and WAV audio formats. 

❺ Canvas 

Add and arrange images and actions on the currently selected page. 

❻ Property Editor 

Edit values for images (positioning, rotation, scale and opacity) and actions. 

❼ Outliner 

Images on your currently selected page. 

❽ Page Navigation 

Add, remove and rearrange pages. 

❸ 

❹ 

❺ 

❼ 

❻ 

❽  

Builder Workspace 

* Unlock, rearrange and resize panels 

  by clicking and dragging different points on a panel‟s edge. You can also 

  show/hide panels from the Top Menu under „View.‟ 

❶ 

❷ 

2. Work Space / 2-1) Panels 

◀ Back to Contents 
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Below are several key functions of the Top Menu, many of which can be performed with keyboard 

shortcuts.  

2-2) Top Menu 

Coming soon 

Show/Hide image Library panel 

Show/Hide action Library panel 

Show/Hide Property Editor panel 

Show/Hide Outliner panel 

Show/Hide Page Navigation panel 

Open Moglue‟s instructional manual 

2. Work Space / 2-2) Top Menu 

◀ Back to Contents 

Create a new book 

Open a previously saved book 

Save your book 

Save your book with a different 

Preview your book on the iOS/Android viewer 

Close the builder 

Import images and 

sounds. Images will 

automatically appear in 

your Image and Sound 

Libraries. 

*supported formats: JPEG, 

GIF, TIF, PNG / MP3, M4A, 

WAV  

Publish your interactive ebook to Moglue‟s store 

Find device to preview 
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Our Toolbar includes the following 17 icons: 

New 

Create a new book 

Open 

Open a previously saved book 

Save 

Save book as an mgl file 

Preview Book 

Preview book  

on iOS/Android device 

2-3) Toolbar 

2. Work Space / 2-3) Toolbar 

◀ Back to Contents 

Preview Current Page  

Preview current page 

on iOS/Android device 
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Image Library 

 

The Image Library is where you‟ll access images you‟ve imported into the builder. Our platform 

supports JPEG, GIF, TIF and PNG image files. 

 

 

 

 

 

 

 

 

 

 

Simply drag & drop images onto the Canvas from the Image Library to begin building your book. 

Import images by going to File > Import. Imported files will automatically be saved to the Moglue 

„images‟ folder. 

2-4) Image & Action Libraries 

2. Work Space / 2-4) Image & Action Libraries 

„Image & Action Library‟ Next Page ▶ 

◀ Back to Contents 



There are two tabs in the Action Library: Action and Sound. You can assign actions and sounds to 

images on the canvas via drag & drop. There are eleven actions, with more on the way. Some 

actions have unique parameters that can be adjusted in the Properties panel: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Multiple actions can be assigned to a single image (an exception is Rotate and Waddle, which 

cannot be applied simultaneously). Go to „Tips and Tricks‟ for advice on mixing actions. 

 

The Sound tab is where you will find audio assets that you‟ve imported into the builder. Sound files 

can be imported by going to File > Import or by clicking the Toolbar‟s „Import‟ icon. Imported 

sound files will automatically be saved in the Moglue „Sounds‟ folder. Our platform supports MP3, 

M4A, MP4 and WAV audio formats. Only one sound may be applied to each image. 
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Action Library 

Blink  

Image will blink 

Parameters: Count / Duration   

Drag  

Image can be dragged and moved 

Fade  

Change image‟s opacity 

Parameters: Opacity / Duration 

Float  

Image will have physics and float on the 

canvas; utilizes accelerometer 

Jump  

Image will jump 

Parameter:  Count / Height / Duration 

Move  

Will move in a straight line 

Parameters: X/Y destination coordinates 

Prev Page 

Transfer page to previous page after 

touching the image. 

Next Page 

Transfer page to next page after 

touching the image. 

Rotate 

Make image rotate.  

Parameters: Angle / Duration  

Scale 

Make change image‟s scale. 

Parameter: Ratio / Duration 

Waddle 

Make image waddle.  

Parameter: Count / Angle / Duration 

Anchor Point XY  

(Left/Top point is X:0/Y:0) 

2. Work Space / 2-4) Image & Action Libraries 

Action Library 

Page To 

Transfer page to where you want 

Wait  

Creates a pause between actions 

Parameter: Delay time 

◀ Back to Contents 



❶ All images have numbered states 

 

 

 

 

 

 

 

 

 

 

 

 

 

❷ States contain actions 

 

 

 

 

 

 

 

 

 

❸ Actions have triggers 
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2-5) States & Triggers 

2. Work Space / 2-5) States & Triggers 

Actions (columns) 

After adding some actions 

State-1 

State1 

State2 

State3 

* State-1 is a global state. Actions here don‟t care what 

state you‟re in, they just wait for triggers. Learn more 

about states and triggers page 12. 

Default After adding some actions 

* All  images have empty state boxes 

(rows) 

State-1 

State1 

State2 

State3 

Cat 

„States & Triggers‟ Next Page ▶ 

◀ Back to Contents 



❹ Images live in states, waiting for triggers to tell them to perform an action 

 

 

 

 

 

 

 

 *There are various options for triggers: 

 

 

 

 

 

 

 

 

 

❺ Actions can be active things, like jumping and rotating 
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2. Work Space / 2-5) States & Triggers 

State-1 

State1 

State2 

State3 

Cat 

*drag & drop actions 

Cat 
Cat 

„States & Triggers‟ Next Page ▶ ◀ „States & Triggers‟ Prev Page  

◀ Back to Contents 



❻ Or passive, like float and wait 

 

 

 

 

 

 

 

 

 

 

 

❼ Triggers can be physical things, like touches and swipes 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

❽ Or passive, like waiting for a previous action to finish or a page to load 
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2. Work Space / 2-5) States & Triggers 

Cat 
Cat 

State-1 

State1 

State2 

State3 

Cat 

'States & Triggers' Next Page ▶ ◀ 'States & Triggers' Prev Page  

◀ Back to Contents 



Actions can be in the same numbered state, but will only act together if they have the same trigger. 

 

A. Waddle and Scale are in  the same state, waiting for the „Touch down‟ trigger. If the cat is in state 

one, and a finger is placed down on the cat, they will occur simultaneously. 

 

 

 

 

 

B. Assuming the cat is in State1, it will simultaneously Rotate and play a sound if Swiped. 

 

 

 

 

 

 

C. If the cat is in State1, all four actions will happen at the same time when a finger is placed down 

on the cat image. 

 

 

 

 

 

 

D. These two actions will not occur at the same time, even though they have the same trigger, as 

they live in different states. 
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2. Work Space / 2-5) States & Triggers 

State-1 

State1 

State2 

State3 

State-1 

State1 

State2 

State3 

Swipe 

State-1 

State1 

State2 

State3 

State-1 

State1 

State2 

State3 

X 

'States & Triggers' Next Page ▶ ◀ 'States & Triggers' Prev Page  

◀ Back to Contents 
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2. Work Space / 2-5) States & Triggers 

❾ Triggers can also target indirect objects 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

State1 

State2 

State1 

State2 

State-1 State-1 

State3 

If the cat is in State2, and the mouse is 

in State1, pressing a finger down on 

the cat will cause the mouse to move. 

Press and hold Ctrl, drag & drop an action to 

another object‟s state box.  

  

„T‟ icon and arrow appears 

Mouse 

'States & Triggers' Next Page ▶ ◀ 'States & Triggers' Prev Page  

◀ Back to Contents 



❶⓿ After an image completes an action, it can remain in that state 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

❶❶ Or move to a new state 
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2. Work Space / 2-5) States & Triggers 

State-1 

State1 

State2 

State3 

Cat 

State-1 

State1 

State2 

State3 

Cat 

Cat 

'States & Triggers' Next Page ▶ ◀ 'States & Triggers' Prev Page  

*Choosing either “Next State: Don‟t Care” or “Next State: 

State „X,‟” where „X‟ is the same as the current state, will 

keep the image in the same state after the action has 

completed. 

◀ Back to Contents 



What is ‘State-1’? 

 

State-1 is a global state. Actions located here respond to triggers regardless of the image‟s current 

state.  

 

Assuming the cat is in State1, pressing down on the cat image will cause the cat to waddle and 

fade simultaneously.  The cat can be dragged and will fade if it is in State3. 

 

 

 

 

 

 

You do not have to use State-1. 
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2. Work Space / 2-5) States & Triggers 

State-1 

State1 

State2 

State3 

State4 

◀ 'States & Triggers' Prev Page  

◀ Back to Contents 



The Canvas is where you will drag & drop imported images from the image Library, assign 

actions and sounds from the action Library, and add text. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Text Box 

Add text by right clicking and selecting „Add Text.‟  
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2-6) Canvas 

Currently, canvas dimension correspond with those of Apple‟s iOS devices. 

You can zoom in/out on the canvas using the slider or pre-set buttons 

Creates a text box and opens our Text Editor  

Brings the selected image to the front 

Sends the selected image to the back 

This context menu is 

opened by right-clicking on 

any image. 

Removes all assigned actions 

Fixes the image to the current position on the canvas 

Sends the to the upper-left corner, sends it to the 

back, and locks it 

2. Work Space / 2-6) Canvas 

*Edit text by double-clicking the text box. 

*Choose colors in the 

Property Editor 

◀ Back to Contents 



Action 

The Property Editor allows you to edit a selected image‟s position (example below), rotation, size 

and transparency. You will soon also be able to edit page settings. 

 

Image Tab 

Clicking an image allows you to edit its properties in the Image tab of the Property Editor. 

 

 

 

 

 

 

 

 

 

 

 

Action Tab 

Selecting an image or one of it‟s assigned actions and then choosing the Action tab will let you 

tweak and adjust preset values for the actions you‟ve assigned to that image.  

 

 

 

 

 

 

 

 

 

              

 

 

 

 

Every action has options for it‟s trigger (what it‟s waiting for), target object (which object it will 

affect), and next state (whether it will remain in the current state or move to a new state). 

17 

2-7) Property Editor 

Location 

How long  

the action will take to 

complete 

2. Work Space / 2-7) Property Editor 

*Learn more about 'States & Triggers' on pages 9-14 

Clicking a sound icon         allows you 

to preview the sound file and edit it 

properties such as repeat. 

◀ Back to Contents 
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Outliner 

 

The outliner shows all of the images on the currently selected page. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Page Navigation 

 

Page Navigation gives you a thumbnail view of every page in your book. You will primarily be 

adding, deleting and rearranging pages in this section. 

 

2-8) Outliner & Page Navigation 

Places a new page to the right of the current selection 

Right-clicking on 

any page will open 

the context menu 

Puts a new page to the left of the current selection 

Removes the selected page 

You can hide/show images 

de-selecting/selecting the 

appropriate check box 

2. Work Space / 2-8) Outliner & Page Navigation 

◀ Back to Contents 
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Previewing 

„Moglue Books‟ contains a store where you can purchase books. It also has a discrete viewer, which 

allows you to preview books on which you are working.  

 

Search the Apple App store for „Moglue Books‟ and install it on your iOS device (coming soon to 

Android). Connect your mobile touch device and computer to the same network.  After installation, 

run the app. 

 

 

 

 

 

 

 

 

 

 

 

From the builder there are multiple ways to preview your book: 

❶ File > Preview 

❷ Clicking the preview icon         in the toolbar       

❸ Ctrl + R 

❹ Ctrl + Shift + R (previews only the currently selected page) 

❺ If more than one device is connected to your network and running „Moglue Books,‟ going to 

File > Preview or pressing Ctrl + F allows you to choose the device on which you would like to 

preview your book. 

 

Preview Loading Page 

3. Previewing Books 

Moglue Books Icon 

Main page 

 of Moglue Books 

◀ Back to Contents 



20 

Publishing 

Coming soon. 

4. Publishing Books 

◀ Back to Contents 



❶ Change an image‟s opacity from 100% to 0% in Property Editor‟s „Image‟ tab (this will be the 

starting alpha). 

 

 

 

 

❷ Assign the „Fade‟ action to the image. Fade can make a visible image fade out, or  

    an invisible image fade in.  

 

 

 

❸ Make sure the image or it‟s „Fade‟ action have been selected. In the Property Editor‟s „Action‟ tab,   

    change the alpha (opacity) value to 100.00 (this will be the ending alpha). 

 

 

 

 

 

 

 

❹ Select a trigger from the drop-down menu. 

 

 

 

 

 

To test your scene, press „Ctrl + R,‟ or select „File‟ and one of the preview options. If „Touch down‟ is 

set as the trigger, pressing down on the device area where the hidden image is located should 

make it appear. 

 

As a trick, set an object‟s transparency to 0% and place it on top of another image. This protect the 

bottom, non-transparent layer from physical triggers like touching/tapping/swiping. 
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5-1) Hidden Images (Easter Eggs!) 

Fade  

*Learn more about 'States & Triggers' on pages 9-14 

5. Tips and Tricks 

◀ Back to Contents 
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❶ Assign the „Move‟ action to an image and set the direction and distance in which you want it to 

move. 

❷ Assign the „Waddle‟ action to the same image. 

 

 

 

 

 

 

 

 

❸ To activate the „Move‟ and „Waddle‟ actions simultaneously, place them in the same state and 

give them the same trigger. 

     type of trigger. 

 

 

 

 

Press „Ctrl + R‟ or click „File‟ and one of your preview options to view the scene. Touching the image 

on your device will make it appear to walk across the screen. 

  

5-2) Walking Duck 

Move  Waddle  

5-3) Falling Leaves 

❶ Assign the „Float‟ action to leaves to some leaves. 

❷ Assign the „Drag‟ action to the same image to make it draggable. 

 

 

 

 

 

 

 

 

❸ To activate „Float‟ and „Drag‟ simultaneously, place them in the same state and give them the 

same trigger. 

Drag  Float  

State-1 

State1 

State2 

State-1 

State1 

State2 

*Learn more about 'States & Triggers' on pages 9-14 

5. Tips and Tricks 

◀ Back to Contents 



❶ Prepare two images of a butterfly: one with open wings, and one with closed wings.  

❷ Assign the „Move‟ action to both images and set them to travel the same distance. 

❸ Assign the „Blink‟ action to the butterfly with open wings. 

 

 

 

 

 

 

 

 

❹ To activate „Move‟ and „Blink‟ actions simultaneously, place them in the same state and give 

them the same trigger. 

 

 

 

 

❺ Bring the butterfly with open wings to the front and overlap the images. 

 

 

 

 

    Touching the butterflies will cause them to move in unison; the blinking butterfly will make   

    them appear as a single butterfly that‟s flapping it‟s wings. 
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5-4) Flapping Butterfly Wings 

Move  Blink  

State-1 

State1 

State2 

*Learn more about 'States & Triggers' on pages 9-14 

5. Tips and Tricks 

◀ Back to Contents 



❶ Prepare three images: a ball, a front rim and net, and a back rim.   

❷ Arrange the images in the following order: 

     

 

 

 

 

    Front rim and net (Bring to front) → ball → back rim (send to back)  

 

❸ Assign the „Move‟ and „Jump‟ actions to the ball. 

 

 

 

 

 

 

 

❹ Set a height parameter high enough to make the ball to appear to go through the hoop 

 

 

 

 

 

 

❺ To activate „Jump‟ and „Move‟ simultaneously, place them in the same state and give them the      

same trigger 

 

 

 

 

   Touching the ball will make it appear to go in the hoop- score! 
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5-5) Goal! 

Move  

Jump  
State-1 

State1 

State2 

*Learn more about 'States & Triggers' on pages 9-14 

5. Tips and Tricks 

◀ Back to Contents 
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Shortcuts 

❶ Ctrl + N :  Create a new book 

❷ Ctrl + O :  Open a previously saved book 

❸ Ctrl + I  :  Import images/sounds 

❹ Ctrl + Shift + S  :  Save as  

❺ Ctrl + R  :  If the „Moglue Books‟ app is open, and your device is connected to the same network 

as your computer, this will preview your book 

❻ Ctrl + Q  :  Close the builder 

▼ Canvas 

❶⓿ Select an image + Delete  :  Remove an image and all it‟s assigned actions 

❶❶ Ctrl + ‘Drag’ or ‘Click’ images :  Select multiple images 

❶❷ Ctrl + ‘Drag’ action from one object’s state to another object’s state :  Interacting with 

one image will trigger an action in the other image 

 

6. Shortcuts 

◀ Back to Contents 




